Location: Testing plugin annotation @ 4bd3f8c639d9 / queries.sparql

Author:
Hugh Sorby <h.sorby@auckland.ac.nz>
Date:
2017-02-02 15:57:28+13:00
Desc:
Remove backup file.
Permanent Source URI:
https://staging.physiomeproject.org/workspace/43a/rawfile/4bd3f8c639d9e8c1b47c77ea5ab264a807dee7a9/queries.sparql

PMR SPARQL endpoint: https://models.physiomeproject.org/pmr2_virtuoso_search

// Find all plugins that conform to the MAP Client plugin API
PREFIX dcterms: <http://purl.org/dc/terms/>
PREFIX swo-x: <http://www.ebi.ac.uk/swo/EXTENSIONS/>

SELECT ?me 
WHERE { 
  ?me dcterms:conforms_to swo-x:MAPClient-Plugin-API 
}


// Find all plugins that conform to the CTK plugin API
PREFIX dcterms: <http://purl.org/dc/terms/>
PREFIX swo-x: <http://www.ebi.ac.uk/swo/EXTENSIONS/>

SELECT ?me 
WHERE { 
  ?me dcterms:conforms_to swo-x:CTKPlugin-API 
}

// Find all plugins that conform to the MAP Client plugin API and have a desktop GUI
PREFIX dcterms: <http://purl.org/dc/terms/>
PREFIX swo: <http://www.ebi.ac.uk/swo/>
PREFIX swo-x: <http://www.ebi.ac.uk/swo/EXTENSIONS/>

SELECT ?me 
WHERE { 
  ?me dcterms:conforms_to swo-x:MAPClient-Plugin-API .
  ?me swo:SWO_0004001 <http://www.ebi.ac.uk/swo/interface/SWO_5000003> 
}