Location: Testing plugin annotation @ 65ac9653f8b4 / queries.sparql

Author:
rjag008 <rjag008@auckland.ac.nz>
Date:
2016-12-15 14:17:01+13:00
Desc:
Update of erraneous plugin type encoding
Permanent Source URI:
https://staging.physiomeproject.org/workspace/43a/rawfile/65ac9653f8b4f3af3072a66dd4f4c155c7a9fc2f/queries.sparql

PMR SPARQL endpoint: https://models.physiomeproject.org/pmr2_virtuoso_search

// Find all plugins that conform to the MAP Client plugin API
PREFIX dcterms: <http://purl.org/dc/terms/>
PREFIX swo-x: <http://www.ebi.ac.uk/swo/EXTENSIONS/>

SELECT ?me 
WHERE { 
  ?me dcterms:conforms_to swo-x:MAPClient-Plugin-API 
}


// Find all plugins that conform to the CTK plugin API
PREFIX dcterms: <http://purl.org/dc/terms/>
PREFIX swo-x: <http://www.ebi.ac.uk/swo/EXTENSIONS/>

SELECT ?me 
WHERE { 
  ?me dcterms:conforms_to swo-x:CTKPlugin-API 
}

// Find all plugins that conform to the MAP Client plugin API and have a desktop GUI
PREFIX dcterms: <http://purl.org/dc/terms/>
PREFIX swo: <http://www.ebi.ac.uk/swo/>
PREFIX swo-x: <http://www.ebi.ac.uk/swo/EXTENSIONS/>

SELECT ?me 
WHERE { 
  ?me dcterms:conforms_to swo-x:MAPClient-Plugin-API .
  ?me swo:SWO_0004001 <http://www.ebi.ac.uk/swo/interface/SWO_5000003> 
}