Location: Testing plugin annotation @ bb89aa1d947a / queries.sparql

Author:
David Nickerson <nickerso@users.sourceforge.net>
Date:
2016-11-30 14:14:39+13:00
Desc:
further example query
Permanent Source URI:
https://staging.physiomeproject.org/workspace/43a/rawfile/bb89aa1d947a3a8f882051b4f70bcb885b36a6bf/queries.sparql

PMR SPARQL endpoint: https://models.physiomeproject.org/pmr2_virtuoso_search

// Find all plugins that conform to the MAP Client plugin API
PREFIX dcterms: <http://purl.org/dc/terms/>
PREFIX swo-x: <http://www.ebi.ac.uk/swo/EXTENSIONS/>

SELECT ?me 
WHERE { 
  ?me dcterms:conforms_to swo-x:MAPClient-Plugin-API 
}


// Find all plugins that conform to the CTK plugin API
PREFIX dcterms: <http://purl.org/dc/terms/>
PREFIX swo-x: <http://www.ebi.ac.uk/swo/EXTENSIONS/>

SELECT ?me 
WHERE { 
  ?me dcterms:conforms_to swo-x:CTKPlugin-API 
}

// Find all plugins that conform to the MAP Client plugin API and have a desktop GUI
PREFIX dcterms: <http://purl.org/dc/terms/>
PREFIX swo: <http://www.ebi.ac.uk/swo/>
PREFIX swo-x: <http://www.ebi.ac.uk/swo/EXTENSIONS/>

SELECT ?me 
WHERE { 
  ?me dcterms:conforms_to swo-x:MAPClient-Plugin-API .
  ?me swo:SWO_0004001 <http://www.ebi.ac.uk/swo/interface/SWO_5000003> 
}