Location: Testing plugin annotation @ ea14584209cf / queries.sparql

Author:
rjag008 <rjag008@auckland.ac.nz>
Date:
2016-12-14 12:18:43+13:00
Desc:
New CTK plugin Annotations added by Jagir
Permanent Source URI:
https://staging.physiomeproject.org/workspace/43a/rawfile/ea14584209cfc918125610c44875f957ab66a585/queries.sparql

PMR SPARQL endpoint: https://models.physiomeproject.org/pmr2_virtuoso_search

// Find all plugins that conform to the MAP Client plugin API
PREFIX dcterms: <http://purl.org/dc/terms/>
PREFIX swo-x: <http://www.ebi.ac.uk/swo/EXTENSIONS/>

SELECT ?me 
WHERE { 
  ?me dcterms:conforms_to swo-x:MAPClient-Plugin-API 
}


// Find all plugins that conform to the CTK plugin API
PREFIX dcterms: <http://purl.org/dc/terms/>
PREFIX swo-x: <http://www.ebi.ac.uk/swo/EXTENSIONS/>

SELECT ?me 
WHERE { 
  ?me dcterms:conforms_to swo-x:CTKPlugin-API 
}

// Find all plugins that conform to the MAP Client plugin API and have a desktop GUI
PREFIX dcterms: <http://purl.org/dc/terms/>
PREFIX swo: <http://www.ebi.ac.uk/swo/>
PREFIX swo-x: <http://www.ebi.ac.uk/swo/EXTENSIONS/>

SELECT ?me 
WHERE { 
  ?me dcterms:conforms_to swo-x:MAPClient-Plugin-API .
  ?me swo:SWO_0004001 <http://www.ebi.ac.uk/swo/interface/SWO_5000003> 
}